Заканчивается поддержка PHP 5.2-5.5 в WordPress

Новой минимально допустимой версией в системных требованиях WordPress станет PHP 5.6.

По всей видимости, изменения произойдут в WordPress 5.2. При этом пользователи старых версий CMS смогут расчитывать на обновления безопасности, но не будут получать основные нововведения.

По данным разработчиков CMS, на текущий момент лишь 2% сайтов с WordPress используют PHP версии 5.2 (напомним, что релиз PHP 5.2 состоялся более 12 лет назад).

Заканчивается поддержка PHP 5.2-5.5 в WordPress

Еще 5% используют PHP 5.3, 8,7% — PHP 5.4, 5,1% — PHP 5.5 (источник). Таким образом, речь идёт о 20,8% пользователей WordPress. Можно сказать, что это весьма существенная цифра.

Отметим, что PHP версий с 7.0 по 7.3 суммарно используют 46,7% пользователей, что, в целом, хороший показатель. Ну а 32,5% проявляют консерватизм, используя PHP 5.6.

Что касается разработчиков WordPress, то они не стремятся сделать переход на свежие версии PHP слишком резким, если верить их собственным заверениям. Тем не менее, хотя новая минимальная поддерживаемая версия PHP это 5.6, на странице рекомендаций значится PHP 7.3 или выше. Свою позицию разработчики CMS аргументируют главным образом тем, что PHP 7.x даёт значительный прирост производительности. Кроме того, его повсеместное распространение откроет новые возможности как перед разработчиками CMS, так и перед авторами плагинов к ней.

Вслед за новыми требованиями к версии PHP мы, скорее всего, увидим повышение минимальной версии MySQL до 5.5. Впрочем, если верить статистике с сайта CMS, версии MySQL ниже 5.5 используют лишь 3,5% сайтов, что сделает подобные потенциальные изменения малозначительными для сообщества.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *